SharpDevelop Community

Get your problems solved!
Welcome to SharpDevelop Community Sign in | Join | Help
in Search

Rebuild for run throws MSB3021 error

Last post 12-15-2011 2:48 PM by tfs. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • 02-18-2011 9:10 AM

    • tfs
    • Not Ranked
    • Joined on 05-08-2010
    • Posts 5

    Rebuild for run throws MSB3021 error

    First of all, i'm not sure whether this is actually a bug within SharpDevelop since you can find reports about this problem all over the web for Visual Studio too. However it's annoying as hell, none of the solutions out there works for me, and since something similar was reported and fixed some time ago i thought i'd better report it.

    There's not much to describe, the problem simply is that evertime a solution is rebuilt for running (F5/CTRL+F5) an MSB3021 error is thrown:

    Unable to copy file "obj\Platform\Configuration\OutputName.exe" to "bin\Configuration\OutputName.exe". The process cannot access the file 'bin\Configuration\OutputName.exe' because it is being used by another process. (MSB3021)

    According to Sysinternals Process Explorer, System seems to keep its hands on the file, once released (takes a few minutes) rebuilding works fine.

    I'm running SharpDevelop 4 (4.0.0, 7070) on Windows 7 Ultimate x64 with an Administrator Account.

    Regards, Tim

    Filed under: , ,
  • 11-01-2011 9:53 AM In reply to

    Re: Rebuild for run throws MSB3021 error

     

    I have the same problem with SharpDevelop version 4.1.0 build 8000, Windows 7 Professional x64, Administrator account.

    I thought that maybe antivirus is causing a problem, but turning it off didn't help. The compiled executable is not running, because this error occurs even if I never try to run the executable.

    This is extremely annoying to deal with, while working on a project in SharpDevelop, 8 hours / day.

  • 12-15-2011 2:48 PM In reply to

    • tfs
    • Not Ranked
    • Joined on 05-08-2010
    • Posts 5

    Re: Rebuild for run throws MSB3021 error

    Sorry for replying so late, but the notification mail got lost in my spam filter... i found out what caused the problem for me, in my case it was the Application Experience Service, to be exact the problem was that it was turned off!

    http://www.retrocopy.com/blog/28/cant-delete-exe-files-in-vista--windows-7-solved.aspx

    Regards, Tim

Page 1 of 1 (3 items)
Powered by Community Server (Commercial Edition), by Telligent Systems
Don't contact us via this (fleischfalle@alphasierrapapa.com) email address.