SharpDevelop Community

Get your problems solved!
Welcome to SharpDevelop Community Sign in | Join | Help
in Search

fail build SD-4.3-Beta1 with buildSetupAndRunTests.bat

Last post 01-12-2013 3:43 PM by gtf. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • 01-12-2013 1:29 PM

    • gtf
    • Not Ranked
    • Joined on 10-26-2011
    • Posts 4

    fail build SD-4.3-Beta1 with buildSetupAndRunTests.bat

    4.3-Beta1 tag from github

    buildSetupAndRunTests.bat produce following error messages:

     

    "D:\Projects\SharpDevelop\src\Automated.proj" (целевой объект по умолчанию) (1) -> (Целевой объект createsetup) ->

      D:\Projects\SharpDevelop\src\Setup\Setup.wxs(35): error LGHT0204: ICE61: Upgrade.VersionMax cannot be equal to Upgrade.VersionMin unless both Min and Max are inclusive, otherwise no version will match. (PREVIOUSVERSIONFOUND) [D:\Projects\SharpDevelop\src\Setup\SharpDevelop.Setup.wixproj] [D:\Projects\SharpDevelop\src\Automated.proj]

      D:\Projects\SharpDevelop\src\Setup\Setup.wxs(35): error LGHT0204: ICE61: Upgrade.VersionMax cannot be equal to Upgrade.VersionMin unless both Min and Max are inclusive, otherwise no version will match. (PREVIOUSVERSIONFOUND) [D:\Projects\SharpDevelop\src\Setup\SharpDevelop.Setup.wixproj] [D:\Projects\SharpDevelop\src\Automated.proj]

      D:\Projects\SharpDevelop\src\Automated.proj(125,3): error MSB3073: Выход из команды ""C:\Windows\Microsoft.NET\Framework\v2.0.50727\..\v4.0.30319\msbuild.exe" SharpDevelop.Setup.sln /p:Configuration=Release "/p:SharpDevelopBinPath=D:\Projects\SharpDevelop\src\..\bin" "/p:BooBinPath=D:\Projects\SharpDevelop\src\..\src\AddIns\BackendBindings\Boo\RequiredLibraries" "/p:FSharpBuildTasksPath=D:\Projects\SharpDevelop\src\..\src\AddIns\BackendBindings\FSharp\RequiredLibraries" "/p:BranchName=" " с кодом 1.

     

  • 01-12-2013 2:37 PM In reply to

    Re: fail build SD-4.3-Beta1 with buildSetupAndRunTests.bat

    Did you download the .zip from github? Unfortunately that doesn't contain any version information.

    The build script needs either a real git working copy to determine the version number; or alternatively use the .zip file from our download site (or alternatively a newer version from our build server) - those .zips have a REVISION file saying from which git version they were created.

  • 01-12-2013 3:27 PM In reply to

    • gtf
    • Not Ranked
    • Joined on 10-26-2011
    • Posts 4

    Re: fail build SD-4.3-Beta1 with buildSetupAndRunTests.bat

    i clone repository from github, then checkout 4.3-Beta1

    it's real git repository

  • 01-12-2013 3:38 PM In reply to

    Re: fail build SD-4.3-Beta1 with buildSetupAndRunTests.bat

    Take a look at output of the build above; there should be a warning about the missing version number (UpdateAssemblyInfo tool). Or run src\Tools\UpdateAssemblyInfo\bin\Debug\UpdateAssemblyInfo.exe manually if you can't find it in the build output.

    Most likely cause: the command-line git is not available in your PATH; and it's not in the default path (C:\Program Files (x86)\Git\bin) either.

  • 01-12-2013 3:43 PM In reply to

    • gtf
    • Not Ranked
    • Joined on 10-26-2011
    • Posts 4

    Re: fail build SD-4.3-Beta1 with buildSetupAndRunTests.bat

    yeah. git is't in the PATH. Thank you. Now, build successfull

Page 1 of 1 (5 items)
Powered by Community Server (Commercial Edition), by Telligent Systems
Don't contact us via this (fleischfalle@alphasierrapapa.com) email address.