SharpDevelop Community

Get your problems solved!
Welcome to SharpDevelop Community Sign in | Join | Help
in Search

Problem running ASP.NET MVC2 32bit app from #Develop using local IIS 7.5 (not the Express) on Windows 7 64bit

Last post 05-13-2013 2:27 AM by gsc-frank. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • 05-10-2013 9:33 PM

    Problem running ASP.NET MVC2 32bit app from #Develop using local IIS 7.5 (not the Express) on Windows 7 64bit

    Hi all,

     

    following two paraghraps are just for context and if some of you know a better way to solve those problems, the real problem follow the next two paraghraps:

    I'm on Windows 7 64bit and have an ASP.NET MVC2 app with some dlls in 32bit. I can run the app using SharpDevelop and my local IIS Express 8.0 (afther execute the command "appcmd set app /app.name:APPLICATION_NAME/ /applicationPool:Clr2IntegratedAppPool"). So the app is working find my problem is related exclusivelly to the following  eployment issue.

    When I try to run the app from SharpDevelop using my local IIS 7.5 (not the Express 8.0 version) hitting the Creating application/virtual directory a error show up saying something about permission, I solve this problem running SharpDevelop as Admin, so I see the app in the IIS Manager. Then when try to execute the app, again, another error saying something about 32bit cannot access modules of a 64bit process, I solve this problem enabling in the IIS AppPool the option to allow execute 32bit app problem solved,

    but now when I run the app, the following error show up:

     

    Could not find file 'C:\inetpub\wwwroot\secureUrls.xml'.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.IO.FileNotFoundException: Could not find file 'C:\inetpub\wwwroot\secureUrls.xml'.

    Source Error: 

    Line 96:             if(HttpContext.Current.Cache["SecureUrls"] == null)
    Line 97:             {
    Line 98:                 result = XDocument.Load(HttpContext.Current.Server.MapPath("/secureUrls.xml"));
    Line 99:                 HttpContext.Current.Cache.Add("SecureUrls", result, null, DateTime.Now.AddMinutes(5), Cache.NoSlidingExpiration, System.Web.Caching.CacheItemPriority.Normal, null);
    Line 100:            }


    Source File: c:\Users\PATH_OF_MY_APP\Code\SecureUrlUtil.cs    Line: 98 

     

    Is like that  the root app is not set to the path where my code is, but to the document root of IIS. What config I must change so code like Line 98 find files in the app dir and not in the IIS document root where my app not have any file?

     

    Thanks in advanced.

    Frank

  • 05-13-2013 2:27 AM In reply to

    Re: Problem running ASP.NET MVC2 32bit app from #Develop using local IIS 7.5 (not the Express) on Windows 7 64bit

    I solved the problem changing  "/secureUrls.xml" by "~/secureUrls.xml"

Page 1 of 1 (2 items)
Powered by Community Server (Commercial Edition), by Telligent Systems
Don't contact us via this (fleischfalle@alphasierrapapa.com) email address.